Actualización del kernel para SuSE Linux Enterprise 12

SuSE ha publicado una actualización del kernel para SuSE Linux Enterprise 12 destinado a solucionar 11 vulnerabilidades que podrían permitir a un atacante provocar denegaciones de servicio, obtener información sensible o elevar sus privilegios en el sistema.

Los problemas corregidos están relacionados con la función proc_keys_show de security/keys/proc.c, la implementación del sistema de archivos en el kernel de Linux mantiene el setgid durante una llamada setxattr, la function rfcomm_sock_bind de net/bluetooth/rfcomm/sock.c, net/ipv4/tcp_input.c del kernel de Linux no determina adecuadamente el ritmo de desafío de los segmentos ACK, una condición de carrera en la función sclp_ctl_ioctl_sccb de drivers/s390/char/sclp_ctl.c y en la función ioctl_send_fib de /scsi/aacraid/commctrl.c.

Por otra parte, un desbordamiento de búfer en la función brcmf_cfg80211_start_ap de drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c y una denegación de servicio en la pila IP del kernel Linux. También vulnerabilidades en drivers/infiniband/ulp/srpt/ib_srpt.c, en la función tcp_check_send_head de include/net/tcp.h, en la función arcmsr_iop_message_xfer de drivers/scsi/arcmsr/arcmsr_hba.c. 

Los CVE asociados a los problemas corregidos son: CVE-2015-8956, CVE-2016-5696, CVE-2016-6130, CVE-2016-6327, CVE-2016-6480, CVE-2016-6828, CVE-2016-7042, CVE-2016-7097, CVE-2016-7425, CVE-2016-8658 y CVE-2016-8666.

Además se han corregido otros 111 problemas no relacionados directamente con fallos de seguridad.

La actualización afecta a:

SUSE Linux Enterprise Workstation Extension 12-SP1

SUSE Linux Enterprise Software Development Kit 12-SP1

SUSE Linux Enterprise Server 12-SP1

SUSE Linux Enterprise Module for Public Cloud 12

SUSE Linux Enterprise Live Patching 12

SUSE Linux Enterprise Desktop 12-SP1

Se recomienda actualizar a la última versión del kernel, disponible a través de la herramienta automática YaST con el módulo “Online Update” o con la herramienta de línea de comando “zypper“.

Más información:

SUSE-SU-2016:2912-1: important: Security update for the Linux Kernel

http://lists.suse.com/pipermail/sle-security-updates/2016-November/002422.html

Fuente: Antonio Ropero (antonior@hispasec.com)

About Gustavo Genez 410 Articles
Informático de corazón y apasionado por la tecnología. La misión de este blog es llegar a los usuarios y profesionales con información y trucos acerca de la Seguridad Informática.