Múltiples vulnerabilidades en Dell EMC Isilon OneFS

Se ha publicado el boletín de seguridad DSA-2018-018 que resuelve 9 vulnerabilidades en Dell EMC Isilon OneFS.




OneFS es un sistema operativo diseñado para ‘big data’ que combina las capas de sistema de archivos, administrador de volúmenes y protección de datos en una capa de software unificada que abarca todos los nodos de un clúster. Es utilizado en las soluciones empresariales de almacenamiento NAS de escalamiento horizontal EMC Isilon.

Las vulnerabilidades se pueden englobar en 4 tipos:

  • Cross-Site Scripting (XSS) persistente en diferentes páginas del interfaz web de administración: el parámetro ‘description‘ en ‘Cluster Description‘ (CVE-2018-1186), la ‘Network Configuration‘ (CVE-2018-1187) y ‘Job Operations‘ (CVE-2018-1201), el parámetro ‘realm‘ en ‘Authorization Providers‘ (CVE-2018-1188), y el parámetro ‘name‘ en ‘Antivirus‘ (CVE-2018-1189) y ‘NDMP’ (CVE-2018-1202).
  • Un error al manejar los permisos podría permitir al usuario ‘compadmin(el cual tiene menores privilegios que el usuario ‘root‘) elevar sus privilegios locales a través de la llamada al binario ‘tcpdump y ejecutar código arbitrario con permisos de ‘root‘ (CVE-2018-1203).
  • Ruta transversal en la aplicación ‘isi_phone_home que podría, al igual que la anterior, permitir a un usuario ‘compadmin‘ ejecutar el código Python arbitrario con privilegios de ‘root‘ (CVE-2018-1204).
  • Falsificación de petición en sitios cruzados (CVE-2018-1213). La falta de tokens ‘anti-CSRF‘ en los formularios de la interfaz web podría permitir a un atacante enviar solicitudes autenticadas (por ejemplo para para agregar nuevos usuarios con acceso SSH o reasignar directorios de almacenamiento existentes para permitir el acceso de lectura-escritura-ejecución a todos los usuarios) cuando un usuario autenticado examine un dominio controlado por un atacante.

Para esta última vulnerabilidad se propone la siguiente prueba de concepto que permite crear un nuevo usuario y asignarle suficientes privilegios para iniciar sesión a través de SSH, configurar identidades, administrar proveedores de autenticación, configurar el clúster y ejecutar las herramientas de soporte remoto.

PoC para la vulnerabilidad CVE-2018-1213


EMC ha liberado actualizaciones para todas las versiones del sistema que se encuentran afectadas: 7.1.1.11, 7.2.1.x, 8.0.0.x, 8.0.1.x y 8.1.0.x.


Juan José Ruiz
jruiz@hispasec.com

Más información:

Dell EMC Isilon OneFS Multiple Vulnerabilities:

Powered by WPeMatico

Entradas relacionadas

About Gustavo Genez 1577 Articles
Informático de corazón y apasionado por la tecnología. La misión de este blog es llegar a los usuarios y profesionales con información y trucos acerca de la Seguridad Informática.