Múltiples vulnerabilidades en productos de WIBU-SYSTEMS

Fecha de publicación: 21/12/2018

Importancia:
Crítica

Recursos afectados:

  • WibuKey.sys, versión 6.40 (Build 2400)
  • Administrador de servidores WibuKey Network, versión 6.40.2402.500

Descripción:

El investigador Marcin ‘Icewall’ Noga, de Cisco Talos, ha descubierto dos vulnerabilidades de divulgación de información de la memoria del kernel y de escalada de privilegios por corrupción de pool en el producto WibuKey.sys, y otra de ejecución remota de código en WibuKey Network.

Solución:

Detalle:

  • Una solicitud IRP especialmente diseñada puede hacer que el controlador devuelva la memoria no inicializada, lo que resulta en la revelación de información de la memoria del kernel. Se ha reservado el identificador CVE-2018-3989 para esta vulnerabilidad.
  • Una petición IRP especialmente diseñada puede causar un desbordamiento de búfer, resultando en corrupción de la memoria del kernel. Se ha reservado el identificador CVE-2018-3990 para esta vulnerabilidad.
  • Un paquete TCP especialmente diseñado puede causar desbordamiento de heap y permitir la ejecución remota de código a nivel de kernel. Se ha reservado el identificador CVE-2018-3991 para esta vulnerabilidad.

Encuesta valoración

Etiquetas:
Actualización, Cisco, Vulnerabilidad

Powered by WPeMatico

Entradas relacionadas

About Gustavo Genez 2816 Articles
Informático de corazón y apasionado por la tecnología. La misión de este blog es llegar a los usuarios y profesionales con información y trucos acerca de la Seguridad Informática.