Vulnerabilidad de path transversal en Bitbucket Data Center de Atlassian

Fecha de publicación: 24/05/2019

Importancia:
Crítica

Recursos afectados:

Bitbucket Data Center versiones:

  • de 6.1.0 hasta 6.1.1
  • de 6.0.0 hasta 6.0.2
  • de 5.16.0 hasta 5.16.2
  • de 5.15.0 hasta 5.15.2
  • de 5.14.0 hasta 5.14.3
  • de 5.13.0 hasta 5.13.5

Descripción:

Johannes Moritz, de RIPS Technologies, ha descubierto una vulnerabilidad de severidad crítica, del tipo path transversal (o incorrecta limitación de rutas de directorios) en la herramienta de migración de Bitbucket Data Center, que puede llevar a la ejecución remota de código en versiones con licencia de Centro de Datos.

Solución:

Atlassian recomienda actualizar a la última versión de Bitbucket Data Center, cuya descripción se puede consultar en las notas de la versión. Puede descargar la última versión de Bitbucket Data Center desde el centro de descargas.

  • Actualice Bitbucket Data Center a la versión 6.1.2 o superior.
  • Si no puede actualizar a 6.1.2, actualize a las versiones siguientes que contienen parches para solucionar esta vulnerabilidad y están disponibles para su descarga:
    • Si está ejecutando las versiones 6.0.x actualice a la versión 6.0.3
    • Si está ejecutando las versiones 5.16.x actualice a la versión 5.16.3
    • Si está ejecutando las versiones 5.15.x actualice a la versión 5.15.3
    • Si está ejecutando las versiones 5.14.x actualice a la versión 5.14.4
    • Si está ejecutando las versiones 5.13.x actualice a la versión 5.13.6

Detalle:

  • Un atacante remoto con usuario autenticado con permisos de administrador puede explotar esta vulnerabilidad de incorrecta limitación de rutas de directorios (path transversal) para escribir archivos en ubicaciones arbitrarias, lo que puede llevar a la ejecución remota de código en sistemas que ejecutan una versión vulnerable de Bitbucket Data Center. Las versiones de Bitbucket Server sin licencia del Centro de Datos no son vulnerables. Se ha reservado el CVE-2019-3397 para esta vulnerabilidad.

Encuesta valoraciĂ³n

Etiquetas:
Actualización, Vulnerabilidad

Powered by WPeMatico

Gustavo Genez

Informático de corazón y apasionado por la tecnología. La misión de este blog es llegar a los usuarios y profesionales con información y trucos acerca de la Seguridad Informática.