Descubierto RCE en iTerm2 de macOS

Se ha descubierto una vulnerabilidad crítica de ejecución remota de código de 7 años en la aplicación de emulador de terminal iTerm2 macOS, uno de los reemplazos de código abierto más populares para la aplicación de terminal incorporada de Mac.

Rastreado como CVE-2019-9535 , la vulnerabilidad en iTerm2 fue descubierta como parte de una auditoría de seguridad independiente financiada por el Programa de Soporte de Código Abierto de Mozilla (MOSS) y realizada por la firma de seguridad cibernética Radically Open Security (ROS).

Según una publicación de blog escrita por Mozilla, la falla de RCE reside en la característica de integración tmux de iTerm2, que, si se explota, podría permitir que un atacante ejecute comandos arbitrarios al proporcionar una salida maliciosa al terminal.

Como se muestra en la demostración en video, los posibles vectores de ataque para esta vulnerabilidad incluyen conectarse a un servidor SSH malicioso controlado por el atacante, usar comandos como curl para buscar un sitio web malicioso o usar tail -f para seguir un archivo de registro que contiene contenido malicioso.

«Por lo general, esta vulnerabilidad requeriría cierto grado de interacción o truco del usuario; pero debido a que puede explotarse a través de comandos generalmente considerados seguros, existe un alto grado de preocupación por el impacto potencial.»

Mozilla

La vulnerabilidad afecta a las versiones de iTerm2 hasta 3.3.5 inclusive, y recientemente se ha parcheado con el lanzamiento de iTerm2 3.3.6, que los usuarios pueden descargar manualmente o buscar actualizaciones dentro del menú de aplicaciones instaladas.

Más información:
https://www.theregister.co.uk/2019/10/10/iterm2_flaw_moss/

Powered by WPeMatico

Gustavo Genez

Informático de corazón y apasionado por la tecnología. La misión de este blog es llegar a los usuarios y profesionales con información y trucos acerca de la Seguridad Informática.